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Welcome to your Excel Intermediate training course 

 Quickly summarise multiple tabs of data 

 Turn long lists and reports into easy to read tables 

 Formulas & formatting to show you cells that pass or fail your business rules 

 Save time by converting your frequently used workbooks into templates 

 Connect spreadsheets so that one updates another 

 Get information at a glance with conditional formatting 

 Reduce human error with conditional formulas 
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Unit 1: Working with Large Worksheets 

In this unit you will learn how to: 

 Adjust the zoom on a spreadsheet 

 Use the Freeze Panes feature 

 Hide rows or columns of data 

 

Viewing and Organising Spreadsheet Data 
It is useful to be familiar with various Excel features that you can use in order to 

make it easier to view and organise data in larger spreadsheets. 

The Zoom Feature 

To adjust the zoom: 

 Use the Zoom Slider switch in the lower right corner of the screen to adjust 

the zoom  

 

 

or 

 Go to View tab, Zoom group 

 

or 

 If you have a central wheel on your mouse, hold down Ctrl and roll the wheel 

forward or backward to increase or decrease zoom by 15% at a time. 
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Using Freeze Panes 

To use Freeze Panes, go to the View tab, Window group, Freeze Panes button 

 

To freeze panes (columns and rows): 

 Select the cell that is below the rows you wish to freeze and to the right of 

the columns you wish to freeze 

 Go to the View tab 

 In the Window group, select Freeze Panes 

To freeze panes (top row only): 

 Go to the View tab 

 In the Window group, select Freeze Top Row 

To freeze panes (first column only): 

 Go to the View tab 

 In the Window group, select Freeze First Column 

To unfreeze panes (any setting): 

 Go to the View tab 

 In the Window group, select Freeze Panes then select Unfreeze Pane 
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Hide rows and columns 

Hiding data serves the purpose of allowing you to temporarily make column or 

rows from your spreadsheet invisible. 

 

To hide data: 

 Right-click the row 

or column header 

for the row/column 

you wish to hide 

 Select Hide from 

the menu 

 

 

 

 

To unhide data: 

 Highlight rows / 

columns either side 

of the hidden one/s 

 Right-click and 

select Unhide from 

the menu 
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Using Automatic Outlining 

Excel’s grouping and outlining features will allow you to collapse a large worksheet 

to show or print summary data, and to expand the same worksheet to show or 

modify the details. 

You will find these features on the Data Ribbon in the Outline button group. 

 

Automatic outlining works best with numerical data organised into groups and 

sub groups by formulas or functions.  

To automatically outline a worksheet: 

 Select the Data tab, and 

locate the Outline group 

 Click the Group button 

 Select Auto Outline 

 The – and + symbols can 

be used to collapse or 

expand sections of data 

respectively. 

 The 1 2 buttons can be 

used to view different 

levels of detail within the 

data 

  

To remove the outlining from your worksheet, select the Data tab, Outline group 

and select the Ungroup drop-down arrow, then Clear Outline. 
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Grouping Data Manually 

Automatic outlining may not be adequate for worksheets with non numerical 

values or with no distinctive totals (from formulas or functions). 

If automatic outlining does not, or cannot, organise your data in the way you want, 

you can manually group your data as required.  

Please refer to the downloadable reference material for instructions on how to 

group data manually. 

 

Printing Large Worksheets 
Printing spreadsheets that are larger than one page often requires adjustment of 

print settings in order to get a hard copy that paginates in an appropriate fashion. 

Print Titles 

The Print Titles feature allows you to select rows and/or columns which contain 

labels that you would like repeated at the top and/or left side of each printed page. 

To access Print Titles: 

 Select the Page Layout tab  

 Go to the Page Setup group  

 Click the Print Titles button 

 Under Print Titles, select the Rows to repeat at the top and/or Columns to 

repeat at left 

 Click OK 
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Page Break Preview 

Excel worksheets can get very large. In fact, most real worksheets contain too much 

data to fit on one printed page. To print a large worksheet, you have to break up 

the data into manageable sections. The point where one contiguous sheet of data 

is broken into separate pages is called a page break.  

 

To view page breaks: 

 Go to the View tab, Workbook Views group, and select the Page Break 

Preview button.  
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You can also access Page Break view by clicking Page Break Preview button  on 

the right-hand side of the status bar. 

You can drag the blue dotted lines with your mouse to adjust where one page ends 

and another begins. 

Inserting a Page Break 

To manually insert a page break: 

 Select the header of the column to the right or row below where the page 

break is to appear 

 Right-click on the column or row header 

 Select Insert Page Break from the menu 

 



 

8 0207 987 3777  www.MicrosoftTraining.net 

Page breaks can also be inserted from the Page Layout tab, Page Setup group, 

Insert Break button. 

 

Printing Multiple Sheets 

Rather than selecting and printing sheets in the same file individually, multiple 

sheets can be printed simultaneously.  

To print all sheets in a workbook: 

 Right-click on the active sheet tab 

 Choose Select All Sheets from the menu. This will create a group of sheets. 

 Use Ctrl + P then press Enter 

 To ungroup sheets, right-click on the sheet tab for the first sheet you 

selected 

 Choose Ungroup Sheets 

To print selected sheets from a workbook: 

 Click the tab for the first sheet you wish to print 

 Hold down the Ctrl key while you click the tabs for the other sheets you 

want to print. This will create a group of sheets. 

 Use Ctrl + P then press Enter 

 To ungroup sheets, right-click on the sheet tab for the first sheet you 

selected 

 Choose Ungroup Sheets 

 



 

www.MicrosoftTraining.net 0207 987 3777 9 

Unit 2: Working with Multiple Worksheets and 

Workbooks 

In this unit you will learn how to: 

 Manage worksheets  

 Create 3D formulas  

 Use the Consolidate feature to create a summary spreadsheet 

 Create and manage links between Excel files  

Using Multiple Worksheets 
The default number of worksheets in a work book is 

three; the maximum number of worksheets is limited 

only by the memory capacity of your PC. 

To create a new worksheet, click the Insert Worksheet 

tab to the right of the existing sheet tabs in your 

workbook (or use the shortcut keys Shift + F11). 

Right-click on a sheet tab to get to the menu below. 

 

Navigating between sheets 

The navigation buttons to the left of the sheet tabs are used to assist with viewing 

sheet tabs. 

Insert Inserts a sheet tab to the left of the present sheet 

Delete Permanently deletes the sheet, cannot delete if there is 

only one sheet 

Rename To display a different name on the sheet tab 

Move or Copy Move or copy the sheet within the workbook or to a 

different workbook 

View Code View the VBA code in any modules in the workbook 

Protect Sheet Apply protection to the worksheet 

Tab Colour Apply colour to the sheet tab 

Hide Temporarily hide the worksheet from view (using Unhide 

will reverse this) 
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The following shortcut keys are also useful: 

Ctrl + Page 

Down 

Make the next tab to the right active 

Ctrl + Page Up Make the next tab to the left active 

 

Creating 3-D formulas 

Instead of calculating with only rows and columns on a single sheet, we can create 

formulas that reference cells on multiple sheets. 

A reference that refers to the same cell or cell range on multiple sheets is called a 

3-D reference. 

To create a 3-D formula using a function: 

 Select the cell where the formula is to be entered  

 Type = (equal sign) 

 Type in the function name (e.g. SUM) followed by an open bracketClick on 

the sheet tab of the first worksheet to be entered into the formula 

 Hold down the Shift key and click on the sheet tab for the last worksheet to 

be entered into the formula 

 On the sheet you have just selected, highlight the cell or range of cells to be 

included in the formula 

 To complete the formula, and press the Enter key  
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Consolidating data 

When you consolidate worksheets, you are combining, condensing, and 

summarising data from multiple sheets into one sheet. For example, a large 

company may have sales or profit data broken down into several different 

geographical locations. Each worksheet would have the same layout and structure 

(template) but contain different data.  

To consolidate worksheets: 

 Open the relevant workbook 

 Select a destination sheet where the data will be consolidated. It is a good 

idea to set up the destination worksheet to be just like the worksheets that 

will supply the data. This means having the same labels and using the same 

layout and cell locations for the same types of data. 

 Select the cell at the upper left of the range that will contain the 

consolidated data. 

 Select the Data Ribbon, and click the Consolidate button in the Data Tools 

group.  

 Under the word Function, select the function you wish to use to combine 

the data. 

 The text field under the word Reference is where you enter the ranges of 

data to be consolidated. Select the ranges from the different worksheets 

with your mouse or keyboard. 

 When a range is entered, click the Add button to add it to the All References 

field. 

 Check the “Use labels in” boxes to consolidate sheets based on row labels 

or column labels. 
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 Check the “Create links to source data” if you wish to have the consolidated 

data updated.  

 Once all options are set, make sure the worksheets and cell ranges to be 

consolidated are correct, and click OK.  

The worksheets will be consolidated and combined into the destination worksheet. 

Linking your workbooks 
To properly manage your workbooks, you should be able to combine or 

consolidate data from more than one workbook or worksheet. By doing this, you 

can provide a clear and unified picture of data that may be spread over multiple 

sources. 

Linking Workbooks 

A cell reference like K7 simply refers to the cell at the intersection of column K and 

row 7. A cell reference like Store!K7 refers to the cell at column K and row 7 in the 

worksheet named Store. Taking this one step further, the reference 

[Sales.xlsx]Store!K7 refers to cell K7 in worksheet Store in the workbook Sales.  

In Excel, a cell in one worksheet can contain a reference to a cell in another 

worksheet or in another workbook. This kind of linking can be useful if you have 

several sheets that have to reference the same pool of data. If you create links, the 

linked cells in the other worksheets or workbooks will be updated automatically 

when you update the source data. 

Using the Paste Link option 

To link two workbooks: 

 Open both workbooks and select the cell or range of source data that you 

want to use from one workbook.  

 Right click on the cell or range and select Copy from the menu.  

 Right click on the cell in the destination workbook that will contain the 

linked data. (If you are linking a range of data, right click on the top left cell 

of the destination range.)  

 Select Paste Special from the pop up menu 



 

www.MicrosoftTraining.net 0207 987 3777 13 

 Click on the Paste Link button in the lower left corner of the Paste Special 

dialogue box. 

 The linked data will now appear in the destination workbook. If you update 

the source data, the linked data will be updated as well. 

Creating a formula to link workbooks 

There is also another way to create links between workbooks – by creating a 

formula. 

 Click on the destination cell and press the = key 

 Click the source data cell in another workbook 

 Press the Enter key. 

 The two workbooks should now be linked, and any data or changes that 

appear in the source cell will be seen in the linked cell as well. 

Controlling link updates 
When the source workbook and the destination workbook are open on the same 

computer, links are updated automatically. When you open a destination 

workbook, and the source workbook is not open, you may be alerted by the Trust 

Bar (see below) whether to update the links. 

You can control whether the Trust Bar alerts you, and whether to update all links 

when the alert does not appear. You can also update only some of the links, if the 

workbook contains more than one link. 
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Manually update all of the links or none of the links in a workbook 

Close all workbooks. If one source workbook is open, and others are closed, the 

updates will not be uniform. Open the workbook that contains the links. To update 

the links, on the Trust Bar, click Enable this Content.  

Manually update only some of the links to other workbooks 

Close all workbooks. Open the workbook that contains the links.  

On the Data tab, in the Connections group, click Edit Links.  

In the Source list, click the linked object that you want to update.  

 To select multiple links, hold down CTRL and click 

each linked object. 

 To select all links, press CTRL + A. 

 Click Update Values. 

Dealing with Broken Links 

If the following message appears on your screen when you are attempting to 

update a linked file, this means that Excel cannot find the source file. This may be 

because the source file has been renamed or moved to a different location. 

To re-establish the link between the two files: 

 Click the Edit Links option to open the Edit Links dialogue box. 

 Select the Change Source button from the Edit Links dialogue box. 

 This will allow you to navigate to the source file. Once you have located the 

source file, select it and click OK. 

 You will then see that the link has been reestablished (note OK showing 

under Status). Any updates of data should have been completed. 

 Click the Close button. 

  

  

 

 



 

www.MicrosoftTraining.net 0207 987 3777 15 

Unit 3: Working with Dates 

In this unit, you will learn how to: 

 Insert and format dates 

 Use dates in formulas 

 Use date functions 

Dates and time in Excel 
Though Microsoft Excel displays dates and times as you would expect, it stores 

them as numbers. 

Dates are stored as the number of days since the beginning of the last century (i.e. 

1-Jan-1900 is day 1). Note that dates before 1900 are stored as text and cannot be 

used in calculations. 

Times are stored as parts of a day – i.e. 12 noon is stored as 1/2 or 0.5. Both the 

date and time can therefore be stored as a single number, the fractional part 

forming the time.  

When entering a date into a cell, Excel will accept various different formats 

(including year/month/day as well as day/month/year). 

Months can be entered as a number or text - the name in full or in an abbreviated 

(three-letter) form. Years abbreviated to 2 figures are taken to be between 1930 

and 2029 - i.e. 31/12/20 is 31-Dec-2020. If the year is omitted, the current year is 

assumed. 

A slash or hyphen (minus sign) can be used to separate the day, month and year. 

Spaces can be used if the month appears as text. 

If Excel recognises data as a date it will appear on the right of the cell - if it appears 

on the left, Excel hasn't recognised it.  

Times are entered into a cell by using a colon to separate the hour, minute and 

second. They also appear right-justified if recognised as valid. Because the time 

represents the fraction of the day, the hour must always be included. Times can be 
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entered with an am/pm suffix if desired (a space must precede am/pm). Both a date 

and time (separated by a space) can be entered into a cell. 

Inserting and formatting dates 

Once a date and/or time has been entered into a cell, various format styles can be 

applied to the data. 

To apply a format: 

 Enter a date into an empty cell and press <Enter> - widen the column, if 

necessary  

 Press <up arrow> to move back to the cell with the date  

 Go to the Home tab, Number group 

 Launch the Format Cells dialogue box 
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 On the Number tab select the Date Category: 

 Select the desired date format from the Type: section 

 Press <Enter> or click on [OK] to apply the chosen format  

Entering date functions 

There are numerous date and time functions in Excel . These can be viewed by 

selecting the Formulas ribbon and clicking the Date & Time button from the 

Function Library group. 

 

Two common functions are:- 

=NOW() Gives today's date and time (e.g. 21/07/2005 09:30) - the two 

brackets are required. 

=TODAY() Gives today's date in date format (e.g. 21/07/2005) 

 

For a list and description of other Date and Time functions, please see the 

downloadable reference material. 

Using dates in formulas 

Because dates (and times) are stored as numbers, they can be used in calculations 

- for example, it's easy to work out the number of days between two dates or 

calculate an employee's wages given an hourly wage rate. 

Some other tasks involving times and dates are less straightforward (for example, 

sorting dates into calendar order, irrespective of the year). 

Date entries can also be used in formulae to give 

answers to your questions, e.g. working out a date 

which is 30 days from the present date. 
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Unit 4: Conditional Formulas and Formatting 

In this unit, you will learn how to: 

 Create IF functions 

 Apply and work with conditional formatting in a spreadsheet 

The IF function 
Excel’s IF function can often prove to be very useful. You can use this function to 

branch to different values or actions depending on a specified condition. The 

structure of an IF function is as follows:  

=IF (logical test, value if true, value if false)  

IF functions are called conditional functions because the value that the function 

returns will depend on whether or not a specific condition is satisfied.  

 

Let’s say that this next IF function is entered into cell B2:  

=IF(A1<=100,A1*.5,C3*2) 

This function states that if the contents of cell A1 is less than or equal to 100, the 

value in cell B2 will be the value in A1 multiplied by .5; otherwise, the value in B2 

will be the value of cell C3 multiplied by 2. 

  



 

www.MicrosoftTraining.net 0207 987 3777 19 

Using the Function Library 

 

 

Excel contains an extensive library of functions that you can call upon to help you 

solve problems. These tools are available in the Function Library button group, on 

the Formulas ribbon.  

The first and largest button is Insert Function. This button will open a dialog 

allowing you to search for and insert hundreds of functions.  

You can also click the small fx button to the left of the formula bar to display the 

Insert Function box. 

 

Clicking the Insert Function button activates the Insert Function dialogue box and 

provides access to the large range of functions available in Excel. 

Once the Insert Function dialogue box is open: 
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 Select the function you wish to use from the available list and click OK or 

 Type the name of the function you wish to use in the Search for a function 

area, press Enter, select the function when it appears in the list and click OK. 

Manually entering a function 

If you know which function you wish to use, you can enter a function into a 

worksheet by inputting it manually (i.e. by typing the function directly into a cell). 

For example, if you type =IF into a cell the following appears. 

 

If there is more than one function listed, you can toggle between them by using 

the arrow up or arrow down keys. 

Once you have selected the function you wish to use, continue by typing in a left 

bracket, (double clicking the function name will add the opening bracket) which 

will cause the function syntax to display in another screen tip. 

 

Continue to enter all the arguments required for the function to give you a result, 

and make sure to type a comma between each argument. 

 

Press Enter to display the result. 
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Conditional Formatting 
In Excel you can design a worksheet in such a way that data is formatted differently, 

based on the values the data assume at any given time. This is called conditional 

formatting.  

Applying Conditional Formatting 

To use conditional formatting: 

 Select a range of data that you want to apply the formatting to. 

 On the Home ribbon, Styles group, click the Conditional Formatting 

button. 

 This will display a menu of conditional formatting options. From this menu, 

you can choose: 

 Select the option you wish to use to apply formatting 
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Highlight Cells 

Rules 

This will highlight cells that are greater than, less 

than, between or equal to values that you can 

specify. 

Top/Bottom Rules  This option will allow you to highlight the top or 

bottom numbers or percent in the selected cells. 

Data Bars  Will display coloured bars that are indicative of the 

value in the cell. This is what is used in the image 

above. 

Colour Scales  Will use different shades of colour to represent 

different values, from low to high.  

Icon Sets  Will use sets of similar icons that will visually indicate 

a cell’s value. 

 

Creating a Conditional Formatting Rule 

If you click the New Rule option near the bottom of the conditional formatting 

menu, you will display the following New Formatting Rule dialogue box. 

In this dialogue box you can configure more precise and specific conditional 

formatting rules. The options in the Edit the Rule Description panel will change as 

you click the different items in the Select a Rule Type panel.  
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Removing Conditional Formatting 

If you want to remove conditional formatting rules, simply use the Clear Rules 

option from the menu. This option will let you clear rules for selected cells or for 

an entire spreadsheet. 

 

Using the Manage Rules Option 

The Manage Rules option will allow you to delete, edit, or add new conditional 

formatting rules. 
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Adding Conditional Formatting using the Quick analysis tool 

Conditional formatting can very fast be added to a range using the Quick Analysis 

tool.  

 Select the range of data 

 Click the icon in the right bottom corner of the select 

 Click on the Conditional Formatting option needed 
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Unit 5: Working with Tables 

In this unit, you will learn how to: 

 Create and change a table range in Excel 

 Sort table data 

 Filter table data 

 Create subtotals 

What is a Table? 

In Excel, a table is a specially designated range of numbers. This special range of 

numbers has added functionality that other cell ranges do not have. You can have 

more than one table in a workbook or worksheet if you want, and tables can be as 

large or small as the amount of data you want to work with. 

Normally a table is made from adjacent columns of data, with a unique label or 

heading for each column. Each row in the table should have entries organised 

according to the column headings. You should keep your table data adjacent in a 

block to take advantage of all of Excel’s table features. Some Excel features, like 

filters and PivotTables, will not work correctly if the data is not blocked together in 

adjacent columns as a table. 

 

  



 

26 0207 987 3777  www.MicrosoftTraining.net 

Creating Tables 

To create a table from an existing range: 

 Pre-select a range of data in adjacent columns or click 

any cell within the required data range 

 On the Home Ribbon, Style group, click on the Format 

as Table button. 

 This will display a menu of table formatting options. If you click on one of 

the table menu options, the selected range will be formatted as a table 

based on the style of your choice. 

 When you choose a table format, you will see a Format as Table dialogue 

box appear. 

 If there are column headings in the first row of the range you selected for 

your table, check the box that says, “My 

table has headers.” 

 Make sure the cell range shown is the 

range that you want for your table;  

 Click the OK button to create your table. 

 

Changing the Table Range 

To change the table range – method 1: 

 Use the small blue move handle in the bottom right corner of the table.  

 Position your mouse on top of the move handle, then hold down your left 

mouse button and drag the move handle to resize the table.  
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To change the table range – method 2: 

 Click on a cell in your table 

 The contextual Design tab appears above the ribbon area of the screen. This 

contains options for working with your table. 

 In the Properties group, click Resize Table button.  

 The Resize Table dialogue will appear on your screen.  

 Select the new table range with your mouse. 

 Click OK and your table will be resized. 

 



 

28 0207 987 3777  www.MicrosoftTraining.net 

Inserting Table Columns 

To add a column to the table: 

 Right click on a cell in the column next to where you want to insert a new 

column. 

 From the menu, choose Insert, and then Table columns to the Left, or 

Table columns to the Right. 

You can also quickly add additional columns to your table by clicking a cell to the 

immediate right of the table and then entering data into the cell. 

Inserting Table Rows 

To add rows to the table: 

 Right click on a cell in the row below where you want to insert. 

 Choose Insert from the menu, and then choose Table Rows Above from 

the submenu. 

You can quickly add a new row to the end of a table by clicking on a cell 

immediately below the table and entering data into it. The new row will 

automatically be included in the table range when you press the Enter key after 

typing your data into the cell. 

Deleting Rows or Columns 

To delete a row from your table: 

 Right click on a cell in the row that you want to remove 

 Select Delete, and then choose the Table Rows option.  

 

To delete a column from a table: 

 Right click on a cell in the column that you want to remove 

 Select Delete, followed by Table Columns, from the menus. 
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Creating a Table Total Row 

If you are working with a table in Excel and you click on a table cell, a contextual 

Table Tools tab should appear containing a Design ribbon. 

 

 Select the Design Ribbon 

 In the Table Style Options group, check the box labeled Total Row.  

 

 

 

 This will display another row at the bottom of the table, with the word Total 

in the first cell.  

 Select a cell in the Totals Row and a drop-down arrow will appear. 

 

 

 Choose a function type from the drop-down list to apply to the particular 

column of data. 

If you drag the move handle to lengthen the table, the Total Row will stay at the 

bottom. 

If you enter any new data into the table the values in the Total Row cells will be 

recalculated accordingly. 

If you want to change what is displayed in the Total Row, you can click on any cell 

in the row and choose another option from the drop-down list. 

You can hide the Total Row by: 
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 Clearing the Total Row checkbox on the Design Ribbon, Table Style 

Options group; or 

 Right click a cell in the table and select Tables then Totals Row. 

Sorting and Filtering Tables 
Excel tables are intended to help users manage, maintain, find, and retrieve data. 

This includes sorting a table, working with AutoFilters, custom AutoFilters, and 

advanced filters.  

Sorting Data in a Table 

To sort a table: 

 Choose a column that you want to sort by 

 Click on the AutoFilter arrow at the top of the column. If you cannot see the 

AutoFilter arrows, select a column heading in your table and then click the 

Filter button on the Data Ribbon. 

 Clicking the AutoFilter arrow will display a drop-down list of options for 

filtering your records. 

 Select Sort Smallest to Largest or Sort Largest to Smallest. 
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You can also sort your table by clicking on a cell in the table and then clicking the 

Sort button on the Data Ribbon.  

 

 

This will display the Sort dialogue. 

 

With the Sort dialogue box: 

 Select a column to sort from the Sort by drop-down list 

 Choose a quality of the given column to sort on (i.e. value, cell colour, or 

font colour) 

 You can then choose the order of the sort. 

 Click the Add Level button and create a Then By sorting rule.  

 Repeat the above steps if you wish to create additional sorting rules 

 When you finish configuring the Sort by dialogue box, click OK 
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What is an AutoFilter? 

An AutoFilter is an Excel feature that lets you filter out rows from a data table. You 

can select an AutoFilter option and only rows that meet the specified criteria will 

be shown. 

To apply an AutoFilter: 

 Click the AutoFilter arrow next to the column heading that contains the 

criteria you wish to display in the filtered data.  

 When you display the AutoFilter drop-down list, you will see the 

corresponding column values from your data table in ascending order. 

Remove the checkmarks next to the items you wish to remove from the filter. 

To remove an AutoFilter: 

 Look for the filter symbol on the AutoFilter drop-down arrow next to the 

column headings – these indicate the column/s that filters have been 

applied to 

 

 Click any drop-down arrows showing the filter symbol and select Clear Filter 

from [Column name] 

 

Custom AutoFilters 

With the custom AutoFilter options, you will be able to set up a customised filter 

for your data table. To create a custom AutoFilter: 

 

 Select a column heading that you want to filter 
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 Choose either Text Filters or Number Filters depending on the type of data 

in the column. 

 

 

 

 For example the Between Number Filter displays this dialogue: 

 

 In this dialogue, you can use the drop down arrows and radio buttons to set 

up filtering criteria for the rows in your table. 

The Custom Filter Text Filter displays the following:  
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You can select the 'And' radio button or the 'Or' radio button to incorporate 

additional criteria into your filter.  

When you use the 'And/Or' radio buttons to build custom filters, remember:  

 For the 'And' option, both conditions (A and B) must be satisfied for a row 

to be shown. 

 With the 'Or' option, rows that satisfy either condition will be shown. 

 

You can use the radio buttons to combine filtering conditions, or just filter based 

on options from the first two drop-down lists.  

Removing Filters 

To remove a custom filter: 

 Look for the filter symbol on the AutoFilter drop-down arrow next to the 

column headings – these indicate the column/s that filters have been 

applied to 

 

 Click any drop-down arrows showing the filter symbol and select Clear Filter 

from [Column name] 

Alternatively: 

 Select a cell within the table range. 

 On the Data tab, Sort & Filter group, click the Clear button. All table data 

is then restored. 

 

Filtering with Wildcard Characters 

In Excel, you can use the question mark (?) or the asterisk (*) as wildcard characters. 

A question mark will substitute a single character in a string, while an asterisk can 

substitute multiple characters in a string. For example, the string “ca?” could be car, 
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cat, can, cap, and so on. The string “tele*” could be television, teleportation, 

telemarketing, and so on.  

 

To see how to use these wild card characters in a filter, please see the downloadable 

reference material. 

Using an Advanced Filter 

If you can’t get the results you want from a custom filter, you can construct your 

own advanced filters to get the most control over your data tables. 

 

To make an advanced filter, you have to set up a range of criteria to filter your table 

with.  

 

 

 

Criteria will consist of the column field heading or headings you are wanting to 

filter from; and the criteria parameters you wish to filter for these fields entered 

directly underneath the column heading/s. 

Criteria should be entered before creating the advanced filter. 

To create an advanced filter: 

 Select any cell in the main data table. 

Criteria 
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 Select the Data ribbon, from the Sort and Filter group click the Advanced 

button. 

 If you wish to filter within the current database, ensure that the Filter the 

list, in-place option is selected in the Action area. 

 If you wish to create a copy of the filter results to be displayed separately 

from the table, choose the Copy to Another Location option and click an 

empty cell with sufficient space below and to the right to allow for the 

placement of the filtered data. The location must be located on the same 

sheet as the data table. 

 In the List Range box, select or enter the cell references for the table. 

 In the Criteria Range box, select or enter the cell references for the criteria 

range. 

 To ensure that only one record is displayed, if some contain exactly the same 

data, turn on the Unique Records Only check box. 

 Click OK. Data in rows not matching the criteria set will be hidden. 

 

To display the full table again, click the Clear button in the Sort & Filter group on 

the Data Ribbon. 

Creating Subtotals 

Another kind of outlining or grouping technique available in Excel is the subtotals 

feature. If you have numeric data organised with clear column and row headings, 

you can use Excel to create automatic subtotals and grand totals for the data.  

 

To use Excel’s subtotal feature: 

1. The first step you must take is to sort the column which will be used in step 4 

in ascending order. 

2. The select the range of data you want to apply subtotals to 

3. Select the Data Ribbon, Outline group and click the Subtotal button.  
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4. The drop-down list under the “At each change in” heading gives you the 

option to select where the subtotals will be inserted within your selected range 

(the sorted column). Totals will be applied every time the values under the 

chosen column label changes. 

5. The “Use function” drop-down list lets you choose which function to apply to 

your data. The function you choose (normally SUM) will be used to calculate 

the totals. 

6. Under the “Add subtotals to” option list, you can select which columns to apply 

the totals to. You can apply totals to a single column or to multiple columns 

in the selected range. 

 

Finally, there are three check boxes at the bottom of the dialogue box that will 

allow you to:  

 Replace any pre existing subtotals 

 Put page breaks between totalled groups so they will be printed on separate 

pages 

 Place the subtotals and grand totals above or below the corresponding data 

To remove subtotals 

 Select the range of data 

 Select the Data Ribbon, Outline group and click the Subtotal button.  

 Click the Remove All button. 

 

 

FlashFill   

Excel notices patterns in the user's data entry and then auto completes the 

remaining data so there’s no need to use formulas or macros to do this. Data gets 
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filled in automatically. Flash Fill is like a data assistant that quickly finishes your 

work for you! 

For example the Flash Fill feature will automatically complete a list of surnames 

after starting to type the second surname. It recognises patterns and predicts what 

data to fill in for you. Start typing the initials and Flash Fill fills the list for you. 

 

Flash Fill also recognises text case. After typing a name in upper case, clicking Flash 

Fill on the Data Ribbon fills all the rest of the names in upper case. 

  



 

www.MicrosoftTraining.net 0207 987 3777 39 

Use Slicers to filter tables 

Although Slicers were introduced with Excel 2010 for use with PivotTables, with 

Excel they can be used to filter tables as well as PivotTables.To insert a Slicer first 

select the Home tab, Format as Table. Then from the Design tab choose Insert 

Slicer. 
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Unit 6: Documenting and Auditing 

In this unit, you will learn how to: 

 Work with comments in a spreadsheet 

 Trace errors in a formula  

 Apply protection to all or part of a worksheet  

 

Comments 
Annotating a spreadsheet is a good idea if you intend on sharing it with other users. 

Your notes will help the people you share your spreadsheet with understand what 

is going on.  

Adding, editing and deleting comments 

The Comments group can be found on the Reviewing tab. 

 

 

 

The New Comment button can be used to add a comment to your spreadsheet. 

You can delete a selected comment with the Delete button, or move between 

comments with the Previous and Next buttons. 

The Show/Hide Comment button will show or hide the comment associated with 

the currently selected cell. The Show All Comments button will show all of the 

comments that have been added to the spreadsheet.  
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The Formula Auditing Group 
The Formula Auditing group can be found on the Formulas ribbon. This group of 

buttons can help you trace errors and show the cells that are referenced in a 

formula. 

The Trace Precedents button will display 

blue arrows to cells that supply data to the 

formula. Arrows may be red if a supplying 

cell has an error. 

The Trace Dependents button will display arrows to the other cells that depend on 

a given cell’s data.  

The Remove Arrows button will remove both precedence and dependence arrows 

from your Excel screen. 

The Show Formulas button will toggle between showing results and formulas in 

the worksheet. You can also use the Ctrl + ‘pipe’ key shortcut keys to do the same 

thing. 

The Error Checking option will check the entire worksheet for formula errors. If any 

are found, you will be alerted with an error checking dialogue (like the one below) 

that pertains to the specific 

error in question. 

You can also click the down 

arrow next to the Error 

Checking button to see 

additional options. 

The first option (Error Checking) will perform the same action as if you clicked the 

Error Checking button directly. The Trace Error option will 

display arrows to the cells referenced in an incorrect formula. 

The Circular References menu will display cells that contain 

circular references, if there are any in the worksheet. 

The Evaluate Formula dialog will help you analyse, interpret, and correct formulas. 
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Last but not least, the Watch Window button will display the watch window 

dialogue (shown below). You can use this dialogue to watch a cell or selection of 

cells (perhaps from another worksheet) while you make changes to the data in 

another area.  

If you find that your formula just isn’t producing the correct results, try the formula 

auditing buttons. These features can help you fix formula mistakes by checking 

your worksheet for errors and tracing cell dependencies so you can see all of the 

cells that are referenced in a formula. 

For further information on troubleshooting the possible causes of formula errors, 

please see the downloadable reference material. 

Excel Workbook and Worksheet Protection 
The information in your Excel workbooks can be very important; and may contain 

crucial data that must not be modified or altered in any way, intentionally or 

otherwise. Protection allows you to control what users can and can’t edit in a 

spreadsheet. 

Protecting your Worksheets 

Excel allows you to protect your data on a worksheet by worksheet basis. This 

feature is useful for situations where users are permitted or required to modify data 

on one worksheet, but are forbidden to modify data in another worksheet in the 

same workbook. 

To protect a worksheet: 

 Select the Review tab, Changes group and click the Protect Sheet button 

 In the dialogue box, you will notice a series of checkboxes. Users will be able 

to perform any tasks that you select with checkmarks, and they will not be 

able to perform any tasks that are not checked.  

 After you set up the tasks that you will allow users to perform, enter a 

password in the Protect Sheet dialogue and click OK.  

 When you enter a password and click OK, Excel will ask you to re-enter the 

password to confirm it. 
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 If you re-enter the password correctly and then click the OK button, the 

worksheet will be protected. 

To unprotect the worksheet 

 Select the Review tab, Changes group and click the Unprotect Sheet 

button 

 Enter the correct password to unprotect the sheet. 

Unlocking Cells 

If you want to prevent users from modifying the actual cell data in your worksheets, 

your cells must be locked and the worksheet must be protected. In Excel the cells 

are locked by default, so when you protect a worksheet, the cell data can no longer 

be modified. If you want users to be able to modify the data in some cells, you 

must unlock the cells that you want to be editable before you protect the 

worksheet.  

To unlock cells in a worksheet 

 Select the cells that you want to unlock 

 Select the Home tab, Font group and click 

the small arrow at the lower right of the 

Font group. 

 When you see the Format Cells dialogue appear, click the Protection tab. 

 Clear the checkmark from the checkbox labeled Locked, and click OK. The 

cells you selected will now be unlocked. 

 When you protect the worksheet with the Protect Sheet button on the 

Review Ribbon, the cells that you selected and unlocked will be editable. 

This means that users can modify the cells that you unlocked, but they can 

do nothing to the data in the other cells in the sheet. 
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Unit 7: Using Templates 

In this unit, you will learn how to: 

 Access and use Excel’s in-built templates  

 Create, modify and use custom templates 

What is a Template? 
A template is a workbook design or layout that can be saved and reused for any 

number of workbooks. A template can have formulas, formats, and a host of other 

Excel features that will be applied to each new workbook that uses the template. 

Creating a Workbook from a Template 

To open a workbook from a template: 

 Select New from the File tab menu.  

 Select a template grouping from the categories listed in the panel on the 

left. 

o Select Installed templates to view inbuilt templates; 

o Select New from Existing to browse for other template files. 

o Select My Templates to view templates saved on the Templates 

folder on your own hard-drive 

 Select the required template file and click Create. 

Creating a Template 

To create your own template, open Excel and design your worksheet or workbook 

layout to meet any specifications you require. You can add labels, formatting, 

colour, borders, and formulas. If need be, you can even create layouts on different 

sheets in the workbook, as a template can contain as many worksheets as you need. 
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Remember, the main purpose of a template is for repeated use of a workbook 

layout. Keep this in mind when creating a template. Plan your layout, labels, and 

formats to make your templates comprehensive and complete. 

 

When you have completed your design: 

 Choose Save As from the File tab menu 

 Click the Browse button 

 In the dialogue, enter a name for your template in the File Name text field. 

 Display the Save As Type drop-down list near the bottom of the dialogue 

box 

 Select the Excel Template option. (You may have to scroll through the list 

of options to find it). This will save the file as filename.xltx.  

 New templates will be automatically saved in the Excel Templates folder. You 

can choose another folder to save your templates in if you wish, but if you 

do, you will need to choose the New from Existing option when creating 

files from the template. 
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Appendix - Excel shortcuts 

KEY DESCRIPTION 

CTRL+SHIFT+( Unhides any hidden rows within the selection. 

CTRL+SHIFT+) Unhides any hidden columns within the selection. 

CTRL+SHIFT+& Applies the outline border to the selected cells. 

CTRL+SHIFT_ Removes the outline border from the selected cells. 

CTRL+SHIFT+~ Applies the General number format. 

CTRL+SHIFT+$ Applies the Currency format with two decimal places (negative 

numbers in parentheses). 

CTRL+SHIFT+% Applies the Percentage format with no decimal places. 

CTRL+SHIFT+^ Applies the Exponential number format with two decimal places. 

CTRL+SHIFT+# Applies the Date format with the day, month, and year. 

CTRL+SHIFT+@ Applies the Time format with the hour and minute, and AM or PM. 

CTRL+SHIFT+! Applies the Number format with two decimal places, thousands 

separator, and minus sign (-) for negative values. 

CTRL+SHIFT+* Selects the current region around the active cell (the data area 

enclosed by blank rows and blank columns). 

In a PivotTable, it selects the entire PivotTable report. 

CTRL+SHIFT+: Enters the current time. 

CTRL+SHIFT+" Copies the value from the cell above the active cell into the cell or 

the Formula Bar. 

CTRL+SHIFT+Plus 

(+) 

Displays the Insert dialogue box to insert blank cells. 

CTRL+Minus (-) Displays the Delete dialogue box to delete the selected cells. 

CTRL+; Enters the current date. 

CTRL+` Alternates between displaying cell values and displaying formulas 

in the worksheet. 

CTRL+' Copies a formula from the cell above the active cell into the cell or 

the Formula Bar. 

CTRL+1 Displays the Format Cells dialogue box. 



 

www.MicrosoftTraining.net 0207 987 3777 47 

CTRL+2 Applies or removes bold formatting. 

CTRL+3 Applies or removes italic formatting. 

CTRL+4 Applies or removes underlining. 

CTRL+5 Applies or removes strikethrough. 

CTRL+6 Alternates between hiding objects, displaying objects, and 

displaying placeholders for objects. 

  

CTRL+8 Displays or hides the outline symbols. 

CTRL+9 Hides the selected rows. 

CTRL+0 Hides the selected columns. 

CTRL+A Selects the entire worksheet.  

If the worksheet contains data, CTRL+A selects the current region. 

Pressing CTRL+A a second time selects the current region and its 

summary rows. Pressing CTRL+A a third time selects the entire 

worksheet. 

When the insertion point is to the right of a function name in a 

formula, displays the Function Arguments dialogue box. 

CTRL+SHIFT+A inserts the argument names and parentheses when 

the insertion point is to the right of a function name in a formula. 

CTRL+B Applies or removes bold formatting. 

CTRL+C Copies the selected cells.  

CTRL+C followed by another CTRL+C displays the Clipboard. 

CTRL+D Uses the Fill Down command to copy the contents and format of 

the topmost cell of a selected range into the cells below. 

  

CTRL+F Displays the Find and Replace dialogue box, with the Find tab 

selected.  

SHIFT+F5 also displays this tab, while SHIFT+F4 repeats the last 

Find action. 

CTRL+SHIFT+F opens the Format Cells dialogue box with the Font 

tab selected. 

CTRL+G  Displays the Go To dialogue box.  

F5 also displays this dialogue box. 

CTRL+H  Displays the Find and Replace dialogue box, with the Replace tab 

selected. 
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CTRL+I Applies or removes italic formatting. 

CTRL+K Displays the Insert Hyperlink dialogue box for new hyperlinks or 

the Edit Hyperlink dialogue box for selected existing hyperlinks. 

CTRL+N  Creates a new, blank workbook. 

CTRL+O  Displays the Open dialogue box to open or find a file. 

CTRL+SHIFT+O selects all cells that contain comments. 

CTRL+P Displays the Print dialogue box. 

CTRL+SHIFT+P opens the Format Cells dialogue box with the 

Font tab selected. 

CTRL+R Uses the Fill Right command to copy the contents and format of 

the leftmost cell of a selected range into the cells to the right. 

CTRL+S Saves the active file with its current file name, location, and file 

format. 

CTRL+T Displays the Create Table dialogue box. 

CTRL+U Applies or removes underlining. 

CTRL+SHIFT+U switches between expanding and collapsing of the 

formula bar.  

CTRL+V  Inserts the contents of the Clipboard at the insertion point and 

replaces any selection. Available only after you have cut or copied 

an object, text, or cell contents. 

CTRL+ALT+V displays the Paste Special dialogue box. Available 

only after you have cut or copied an object, text, or cell contents 

on a worksheet or in another program. 

CTRL+W Closes the selected workbook window. 

CTRL+X  Cuts the selected cells. 

CTRL+Y Repeats the last command or action, if possible. 

CTRL+Z Uses the Undo command to reverse the last command or to delete 

the last entry that you typed. 

CTRL+SHIFT+Z uses the Undo or Redo command to reverse or 

restore the last automatic correction when AutoCorrect Smart Tags 

are displayed. 
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Function keys 

KEY DESCRIPTION 

F1 Displays the Microsoft Office Excel Help task pane. 

CTRL+F1 displays or hides the Ribbon, a component of the Microsoft Office 

Fluent user interface. 

ALT+F1 creates a chart of the data in the current range. 

ALT+SHIFT+F1 inserts a new worksheet. 

F2 Edits the active cell and positions the insertion point at the end of the cell 

contents. It also moves the insertion point into the Formula Bar when editing in a 

cell is turned off. 

SHIFT+F2 adds or edits a cell comment. 

CTRL+F2 displays the Print Preview window. 

F3 Displays the Paste Name dialogue box. 

SHIFT+F3 displays the Insert Function dialogue box. 

F4 Repeats the last command or action, if possible. 

CTRL+F4 closes the selected workbook window. 

F5 Displays the Go To dialogue box. 

CTRL+F5 restores the window size of the selected workbook window. 

F6 Switches between the worksheet, Ribbon, task pane, and Zoom controls. In a 

worksheet that has been split (View menu, Manage This Window, Freeze Panes, 

Split Window command), F6 includes the split panes when switching between 

panes and the Ribbon area.  

SHIFT+F6 switches between the worksheet, Zoom controls, task pane, and 

Ribbon. 

CTRL+F6 switches to the next workbook window when more than one workbook 

window is open. 

F7 Displays the Spelling dialogue box to check spelling in the active worksheet or 

selected range. 

CTRL+F7 performs the Move command on the workbook window when it is not 

maximized. Use the arrow keys to move the window, and when finished press 

ENTER, or ESC to cancel. 
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F8 Turns extend mode on or off. In extend mode, Extended Selection appears in 

the status line, and the arrow keys extend the selection. 

SHIFT+F8 enables you to add a nonadjacent cell or range to a selection of cells 

by using the arrow keys. 

CTRL+F8 performs the Size command (on the Control menu for the workbook 

window) when a workbook is not maximized. 

ALT+F8 displays the Macro dialogue box to create, run, edit, or delete a macro. 

F9 Calculates all worksheets in all open workbooks. 

SHIFT+F9 calculates the active worksheet. 

CTRL+ALT+F9 calculates all worksheets in all open workbooks, regardless of 

whether they have changed since the last calculation. 

CTRL+ALT+SHIFT+F9 rechecks dependent formulas, and then calculates all cells 

in all open workbooks, including cells not marked as needing to be calculated. 

CTRL+F9 minimizes a workbook window to an icon. 

F10 Turns key tips on or off. 

SHIFT+F10 displays the shortcut menu for a selected item. 

ALT+SHIFT+F10 displays the menu or message for a smart tag. If more than one 

smart tag is present, it switches to the next smart tag and displays its menu or 

message. 

CTRL+F10 maximizes or restores the selected workbook window. 

F11 Creates a chart of the data in the current range. 

SHIFT+F11 inserts a new worksheet. 

ALT+F11 opens the Microsoft Visual Basic Editor, in which you can create a macro 

by using Visual Basic for Applications (VBA). 

F12 Displays the Save As dialogue box. 
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Other useful shortcut keys 

KEY DESCRIPTION 

ARROW 

KEYS 

Move one cell up, down, left, or right in a worksheet.  

CTRL+ARROW KEY moves to the edge of the current data region in a 

worksheet. 

SHIFT+ARROW KEY extends the selection of cells by one cell. 

CTRL+SHIFT+ARROW KEY extends the selection of cells to the last 

nonblank cell in the same column or row as the active cell, or if the next 

cell is blank, extends the selection to the next nonblank cell. 

LEFT ARROW or RIGHT ARROW selects the tab to the left or right when 

the Ribbon is selected. When a submenu is open or selected, these arrow 

keys switch between the main menu and the submenu. When a Ribbon 

tab is selected, these keys navigate the tab buttons. 

DOWN ARROW or UP ARROW selects the next or previous command 

when a menu or submenu is open. When a Ribbon tab is selected, these 

keys navigate up or down the tab group. 

In a dialogue box, arrow keys move between options in an open drop-

down list, or between options in a group of options. 

DOWN ARROW or ALT+DOWN ARROW opens a selected drop-down list. 

BACKSPACE Deletes one character to the left in the Formula Bar. 

Also clears the content of the active cell. 

In cell editing mode, it deletes the character to the left of the insertion 

point. 

DELETE Removes the cell contents (data and formulas) from selected cells without 

affecting cell formats or comments.  

In cell editing mode, it deletes the character to the right of the insertion 

point.  

END Moves to the cell in the lower-right corner of the window when SCROLL 

LOCK is turned on. 

Also selects the last command on the menu when a menu or submenu is 

visible. 

CTRL+END moves to the last cell on a worksheet, in the lowest used row 

of the rightmost used column. If the cursor is in the formula bar, 

CTRL+END moves the cursor to the end of the text.  

javascript:AppendPopup(this,'861855245_1')


 

52 0207 987 3777  www.MicrosoftTraining.net 

CTRL+SHIFT+END extends the selection of cells to the last used cell on 

the worksheet (lower-right corner). If the cursor is in the formula bar, 

CTRL+SHIFT+END selects all text in the formula bar from the cursor 

position to the end—this does not affect the height of the formula bar.  

ENTER Completes a cell entry from the cell or the Formula Bar, and selects the 

cell below (by default). 

In a data form, it moves to the first field in the next record. 

Opens a selected menu (press F10 to activate the menu bar) or performs 

the action for a selected command. 

In a dialogue box, it performs the action for the default command button 

in the dialogue box (the button with the bold outline, often the OK 

button). 

ALT+ENTER starts a new line in the same cell. 

CTRL+ENTER fills the selected cell range with the current entry. 

SHIFT+ENTER completes a cell entry and selects the cell above. 

ESC Cancels an entry in the cell or Formula Bar.  

Closes an open menu or submenu, dialogue box, or message window. 

It also closes full screen mode when this mode has been applied, and 

returns to normal screen mode to display the Ribbon and status bar 

again. 

HOME Moves to the beginning of a row in a worksheet. 

Moves to the cell in the upper-left corner of the window when SCROLL 

LOCK is turned on. 

Selects the first command on the menu when a menu or submenu is 

visible. 

CTRL+HOME moves to the beginning of a worksheet. 

CTRL+SHIFT+HOME extends the selection of cells to the beginning of the 

worksheet. 

PAGE 

DOWN 

Moves one screen down in a worksheet.  

ALT+PAGE DOWN moves one screen to the right in a worksheet. 

CTRL+PAGE DOWN moves to the next sheet in a workbook. 

CTRL+SHIFT+PAGE DOWN selects the current and next sheet in a 

workbook. 
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PAGE UP Moves one screen up in a worksheet. 

ALT+PAGE UP moves one screen to the left in a worksheet. 

CTRL+PAGE UP moves to the previous sheet in a workbook. 

CTRL+SHIFT+PAGE UP selects the current and previous sheet in a 

workbook. 

SPACEBAR In a dialogue box, performs the action for the selected button, or selects 

or clears a check box. 

CTRL+SPACEBAR selects an entire column in a worksheet. 

SHIFT+SPACEBAR selects an entire row in a worksheet. 

CTRL+SHIFT+SPACEBAR selects the entire worksheet.  

 If the worksheet contains data, CTRL+SHIFT+SPACEBAR selects the 

current region. Pressing CTRL+SHIFT+SPACEBAR a second time selects 

the current region and its summary rows. Pressing 

CTRL+SHIFT+SPACEBAR a third time selects the entire worksheet.  

 When an object is selected, CTRL+SHIFT+SPACEBAR selects all objects on 

a worksheet. 

ALT+SPACEBAR displays the Control menu for the Microsoft Office Excel 

window. 

TAB Moves one cell to the right in a worksheet. 

Moves between unlocked cells in a protected worksheet. 

Moves to the next option or option group in a dialogue box. 

SHIFT+TAB moves to the previous cell in a worksheet or the previous 

option in a dialogue box. 

CTRL+TAB switches to the next tab in dialogue box. 

CTRL+SHIFT+TAB switches to the previous tab in a dialogue box. 

 

 

E&OE 

STL Training reserves the right to revise this publication and make changes from 

time to time in its content without notice. 
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